MKVToolNix v60.0.0 released

Heya everyone.

Here’s a new release of MKVToolNix: v60. It includes a substantial amount of improvements for BCP 47/RFC 5646 language tags. It also fixes a nasty bug in the HEVC code that could lead to a loss of some frames when appending HEVC tracks under certain circumstances.

Nothing’s changed for package maintainers this time around.

You can download the source code or one of the binaries. The Windows and macOS binaries as well as the Linux AppImage are available already. The other Linux binaries are stil being built and will be available over the course of the next couple of hours.

Here are the NEWS since the previous release:

New features and enhancements

  • all: IETF BCP 47/RFC 5646 language tags: added support for language families from ISO 639-5 that aren’t part of 639-2.
  • all: IETF BCP 47/RFC 5646 language tags: implemented support for Alpha 2 country codes of the “user-defined” category: AA, QMQZ, XAXZ and ZZ.
  • all: IETF BCP 47/RFC 5646 language tags: updated the various lists of valid subtags from the official specs.
  • MKVToolNix GUI: multiplexer: pressing the keyboard shortcut for the track’s “Language” label (Alt+L for English) will now open the language dialog.
  • MKVToolNix GUI: multiplexer: added an option in the preferences for turning off the colored boxes indicating which file each track belongs to.

Bug fixes

  • all: IETF BCP 47/RFC 5646 language tags: fixed validating extended language & variant subtags against their allowed prefixes (e.g. a valid tag with a country code as in de-CH-1996 is recognized as valid while two generally known variants that aren’t allowed together as in de-1901-1996 is recognized as invalid).
  • all: IETF BCP 47/RFC 5646 language tags: when looking up a language for a two- or three-letter code, the programs will no longer compare that code with language names as that was unintended, ambiguous (e.g. the code “Ga” could be interpreted as the 639-2 alpha-2 code for “Irish” or as the name of the language called “Ga”) and only worked with languages whose name was at most three letters long.
  • mkvmerge: HEVC/H.265: appending Matroska files with HEVC tracks might lead to the loss of the first couple of frames from each of the second and all following files. Fixes #3170.
  • mkvmerge, mkvextract: HEVC/H.265 parser: fixed the programs aborting when parsing VPS or SPS NALUs with invalid content due to unhandled exceptions. Fixes #3162.
  • MKVToolNix GUI: multiplexer: when the option “use legacy MIME types for font attachments” is enabled, the GUI will now use application/x-truetype-font for font collection files.
  • MKVToolNix GUI: multiplexer: fixed escaping the mkvmerge argument in the “Show command-line options” dialog for the “Windows (cmd.exe)” mode. Fixes #3164.
  • MKVToolNix GUI: multiplexer: when adding multiple files at once, the GUI will sort file names with numbers the way a human would expect it to. For example, 1.mp4, 9.aac, 10.srt, 11.srt are now sorted exactly that order instead of 1.mp4, 10.srt, 11.srt, 9.aac.
  • MKVToolNix GUI: header editor: the header editor will now honor the “use legacy MIME types when adding font attachments” setting when adding new attachments.

Have fun 😎

5 thoughts on “MKVToolNix v60.0.0 released

  1. Luis Octavio Rodriguez

    No soy un programador. Compré la licencia del programa MKVToolNix y al abrirlo me dice que hay una nueva version 60.0.0 y no se como hacer la actualización. La página de enlace me muestra una cantidad de ventanas con información que para mi es desconocida. Me puede indicar de una manera sencilla como hacer la actualización. Gracias

    Reply
    1. mosu Post author

      The only place where you can actually buy MKVToolNix is the Microsoft Store. If you install via the store, the store will keep the installed version up to date automatically.

      I just gave that a try: installing from the store does install the current version, v60.

      Maybe you had an earlier version installed manually, and you started that one? Dunno. Try uninstalling via Windows’ preferences & then re-installing from the Microsoft Store.

      You can manually download and install, too, by going to the downloads page’s “Windows” section and clicking on the link called “download from fosshub.com”. Ignore all the other numbers there.

      Reply
  2. Wes

    I’m sure this has been asked before, but is it really necessary to force the use of QMimeDatabase everywhere? On a headless server, non-gui server this pulls in a tremendous number of additional packages just to do one single thing. And if I’m understanding correctly, it is mainly because some supported platform doesn’t update their magic file often enough? Both the old and new code looks very simple, couldn’t it both be used and fall back to libmagic if Qt isn’t found? Please?

    Reply
    1. mosu Post author

      No, sorry. Qt isn’t just required for QMimeDatabase, but also for QRegularExpression which allowed me to remove functions & support for two (!) other regex libraries at the same time on top of the removal of the libmagic support. Additionally, libmagic doesn’t support paths with Unicode characters on Windows, making it rather painful to use there. I simply wasn’t willing to spend that much time on complicated libraries when I could just unify all the efforts by switching to using Qt in the CLI apps, too.

      And really, if all you’re concerned about is some more used up HDD space, that really is of no concern to me, cause this whole switch saves me my most valued resource, and that isn’t money: it’s my free time. Considerably.

      Reply
      1. Wes

        It’s nothing to do with storage space, but rather the additional packages that may have security issues.

        Thanks, for your free time, though.

        Reply

Leave a Reply

Your email address will not be published. Required fields are marked *